package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9a-zA-Z]+(?:\s*,\s*[0-9a-zA-Z]+)*$`)
var str = `abc,def
abc, def
abc,def, &&778
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}