$re = '/[a-z]{2,}-?/i';
$str = 'AK-747
AK747
AK-
AK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);