package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@(?<domain>[^\>]+)`)
var str = `Return-Path:<someName@someDomain.com>
Return-Path:<someName@someDomain.com.blah>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}