import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0-9][a-zA-Z0-9-_.\\\\h+]{4,8}+(?>[a-zA-Z0-9-_.\\\\h+]{2}(?>[a-zA-Z0-9-_.\\\\h+]{2,19})?)?$";
final String string = "1bcd\n"
+ "1bcde\n"
+ "1bcdef\n"
+ "1bcdefg\n"
+ "1bcdefgh\n"
+ "1bcdefghi\n"
+ "1bcdefghij\n"
+ "1bcdefghijk\n"
+ "1bcdefghijkl\n"
+ "1bcdefghijklm\n"
+ "1bcdefghijklmnopqrstuvwxyzabc\n"
+ "1bcdefghijklmnopqrstuvwxyzabcd\n"
+ "1bcdefghijklmnopqrstuvwxyzabcde\n"
+ "1bcdefghijklmnopqrstuvwxyzabcdefghijk\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}