package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((([a-z0-9][a-z0-9\-]*[a-z0-9])|[a-z0-9])\.?)+$`)
var str = `dicas-l.com.br`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}