#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*KGM.*\R(?!.*MTQ)"
Local $sString = "1 MEA+AAE+AAB+KGM:5270.000'" & @CRLF & _
"2 MEA+AAE+AAW+MTQ:66.500' <-- OK" & @CRLF & _
"3 MEA+AAE+AAB+KGM:5158.000' <-- NOT OK" & @CRLF & _
"4 MEA+AAE+AAB+KGM:6634.000' <-- NOT OK" & @CRLF & _
"5 MEA+AAE+AAB+KGM:5081.000' <-- NOT OK" & @CRLF & _
"6 MEA+AAE+AAB+KGM:21106.000'" & @CRLF & _
"7 MEA+AAE+AAW+MTQ:25.000' <-- OK "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")