using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*KGM.*\R(?!.*MTQ)";
string input = @"1 MEA+AAE+AAB+KGM:5270.000'
2 MEA+AAE+AAW+MTQ:66.500' <-- OK
3 MEA+AAE+AAB+KGM:5158.000' <-- NOT OK
4 MEA+AAE+AAB+KGM:6634.000' <-- NOT OK
5 MEA+AAE+AAB+KGM:5081.000' <-- NOT OK
6 MEA+AAE+AAB+KGM:21106.000'
7 MEA+AAE+AAW+MTQ:25.000' <-- OK ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}