use strict;
my $str = '1 MEA+AAE+AAB+KGM:5270.000\'
2 MEA+AAE+AAW+MTQ:66.500\' <-- OK
3 MEA+AAE+AAB+KGM:5158.000\' <-- NOT OK
4 MEA+AAE+AAB+KGM:6634.000\' <-- NOT OK
5 MEA+AAE+AAB+KGM:5081.000\' <-- NOT OK
6 MEA+AAE+AAB+KGM:21106.000\'
7 MEA+AAE+AAW+MTQ:25.000\' <-- OK ';
my $regex = qr/.*KGM.*\R(?!.*MTQ)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}