// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sx)(?sx)
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))").unwrap();
let string = "blue cheese, a red nose.
bleu rouge";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}