use strict;
my $str = 'blue cheese, a red nose.
Dictionary:blue=bleu:red=rouge:green=vert';
my $regex = qr/(?s)\b(blue|red)\b(?=.*:\1=(\w+)\b)/sp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";