# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sx)
Container\("\w+"\)\.(?:TextCtrls|LabelCtrls)\("(?<ControlName>\w+)"\).Text/\1\2/gsx;t' <<< "Container(\"Name1\").TextCtrls(\"Name2\").Text
Container(\"Name1\").LabelCtrls(\"Name2\").Text"