$re = '/L(?=\d{4}$)/m';
$str = 'Some Text L1234
Some Other Text L5587';
$subst = "A";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;