$re = '/^[A-Z][0-9]{7}/m';
$str = 'A1234567
1234567
C1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);