using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[uU](?=\b|\d)\.?\s*";
string substitution = @"utca ";
string input = @"Holics u 5/a"",
""Holics U 5/a"",
""Holics u5/a"",
""Huolics u 5/a"",
""Holics u. 5/a"",
""Holuics u5"",
""Holics and other stuff u more stuff after 5"",
""Houlics utca 5";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}