re = /\b[uU](?=\b|\d)\.?\s*/m
str = 'Holics u 5/a",
"Holics U 5/a",
"Holics u5/a",
"Huolics u 5/a",
"Holics u. 5/a",
"Holuics u5",
"Holics and other stuff u more stuff after 5",
"Houlics utca 5'
subst = 'utca '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result