# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[uU](?=\b|(?![^\W\d_]))\.?\s*"
test_str = ("Holics u 5/a\",\n"
" \"Holics U 5/a\",\n"
" \"Holics u5/a\",\n"
" \"Huolics u 5/a\",\n"
" \"Holics u. 5/a\",\n"
" \"Holuics u5\",\n"
" \"Holics and other stuff u more stuff after 5\",\n"
" \"Houlics utca 5")
subst = "utca "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.