#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{1,2}) ((д\.)|(дней)|(день))( назад)?"
Local $sString = "6 д." & @CRLF & _
"23 д." & @CRLF & _
"12 дней" & @CRLF & _
"61 день" & @CRLF & _
"15 дней назад" & @CRLF & _
"62 дней назад" & @CRLF & _
"" & @CRLF & _
"5 ч" & @CRLF & _
"6 нед." & @CRLF & _
"три минуты назад" & @CRLF & _
"час назад" & @CRLF & _
"два часа назад"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")