using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,2}) ((д\.)|(дней)|(день))( назад)?";
string input = @"6 д.
23 д.
12 дней
61 день
15 дней назад
62 дней назад
5 ч
6 нед.
три минуты назад
час назад
два часа назад";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}