const regex = /(\d{1,2}) ((д\.)|(дней)|(день))( назад)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,2}) ((д\\.)|(дней)|(день))( назад)?', 'g')
const str = `6 д.
23 д.
12 дней
61 день
15 дней назад
62 дней назад
5 ч
6 нед.
три минуты назад
час назад
два часа назад`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}