re = /(\d{1,2}) ((д\.)|(дней)|(день))( назад)?/
str = '6 д.
23 д.
12 дней
61 день
15 дней назад
62 дней назад
5 ч
6 нед.
три минуты назад
час назад
два часа назад'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end