import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{13})|(\\d{1}\\s\\d{4}\\s\\d{5}\\s\\d{2}\\s\\d{1})|(\\d{5}\\s\\d{5}\\s\\d{3})|(\\d{5}\\s\\d{5}\\s\\d{2}\\s\\d{1})|(\\d{1}\\-?\\d{4}\\-?\\d{5}\\-?\\d{2}\\-?\\d{1})";
final String string = "1100800612202\n"
+ "1 1008 00612 20 2\n"
+ "11008 00612 202\n"
+ "11008 00612 20 2\n"
+ "1-1008-00612-20-2\n"
+ "11008-00612-202\n"
+ "11008-00612-20-2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}