import Foundation
let pattern = #"(\d{13})|(\d{1}\s\d{4}\s\d{5}\s\d{2}\s\d{1})|(\d{5}\s\d{5}\s\d{3})|(\d{5}\s\d{5}\s\d{2}\s\d{1})|(\d{1}\-?\d{4}\-?\d{5}\-?\d{2}\-?\d{1})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1100800612202
1 1008 00612 20 2
11008 00612 202
11008 00612 20 2
1-1008-00612-20-2
11008-00612-202
11008-00612-20-2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)