use strict;
my $str = '"username":"username"
"phonenumber":"123 456 7890"
"race":"undisclosed"
"gender":"female"
"birthdate":"03/12/1889"
"geodata":"123 456 7890"
"phonenumber":"123 456 7890"
"geodata":"38.897957"';
my $regex = qr/(?i)(\s*)(|"|')(name|phoneNumber|race|gender|birthdate|geodata)(|"|')(\s*)(:|=)(\s*)('|"|\s*)(\s*)(^$|.*?)(\s*)('|,|"|\))/mp;
my $subst = '$1$2$3$4$5$6$7$8$9*******$11$12';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";