using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((--(?P<HELP>help).*)|((?:-s|--separator)\s(?P<SEP>.*?)\s)?((?P<OP1>-?\d+))(\s(?P<OP2>-?\d+))?(\s(?P<OP3>-?\d+))?)$";
string input = @"-s T 10
--help
3 13 2
--separator T 3 11
wrong argument
-s test1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}