package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((--(?P<HELP>help).*)|((?:-s|--separator)\s(?P<SEP>.*?)\s)?((?P<OP1>-?\d+))(\s(?P<OP2>-?\d+))?(\s(?P<OP3>-?\d+))?)$`)
var str = `-s T 10
--help
3 13 2
--separator T 3 11
wrong argument
-s test1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}