import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((--(?P<HELP>help).*)|((?:-s|--separator)\\s(?P<SEP>.*?)\\s)?((?P<OP1>-?\\d+))(\\s(?P<OP2>-?\\d+))?(\\s(?P<OP3>-?\\d+))?)$";
final String string = "-s T 10\n"
+ "--help\n"
+ "3 13 2\n"
+ "--separator T 3 11\n"
+ "wrong argument\n"
+ "-s test1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}