const regex = /^((--(?P<HELP>help).*)|((?:-s|--separator)\s(?P<SEP>.*?)\s)?((?P<OP1>-?\d+))(\s(?P<OP2>-?\d+))?(\s(?P<OP3>-?\d+))?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((--(?P<HELP>help).*)|((?:-s|--separator)\\s(?P<SEP>.*?)\\s)?((?P<OP1>-?\\d+))(\\s(?P<OP2>-?\\d+))?(\\s(?P<OP3>-?\\d+))?)$', 'gm')
const str = `-s T 10
--help
3 13 2
--separator T 3 11
wrong argument
-s test1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}