using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(HORIZON-\S+-[A-Z]\d-\d{2}\S*)(?:\r?\n(?!Opening\b).*)*\r?\nOpening: (\d{2} [A-Z][a-z]{2} \d{4})\r?\nDeadline\(s\): (\d{2} [A-Z][a-z]{2} \d{4}.*)";
string input = @"
HORIZON-CL5-2021-D1-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021
Opening: 15 Apr 2021
Deadline(s): 07 Sep 2021
HORIZON-CL5-2022-D1-01-two-stage
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2022
Opening: 04 Nov 2021
Deadline(s): 15 Feb 2022 (First Stage), 07 Sep 2022 (Second Stage)
HORIZON-CL5-2021-D2-01
Conditions for the Call
Indicative budget(s)
Topics Type of Action Budgets (EUR million) Expected EU contribution per project (EUR million) Number of projects expected to be funded
2021 2022
Opening: 15 Apr 2021
Deadline(s): 19 Oct 2021";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}