#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"12:" & @CRLF & _
"12:3" & @CRLF & _
"12:30" & @CRLF & _
"1:" & @CRLF & _
"1:3" & @CRLF & _
"1:30" & @CRLF & _
"" & @CRLF & _
"25:00" & @CRLF & _
"25" & @CRLF & _
"253"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")