package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$`)
var str = `0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}