use strict;
my $str = '0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253';
my $regex = qr/^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}