// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[01]\d?|2[0-3]?)(?::(?:[0-5]\d?)?)?$").unwrap();
let string = "0
1
12
12:
12:3
12:30
1:
1:3
1:30
25:00
25
253";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}