package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z][a-z]+(\s|,)[A-Z][a-z]{1,19}`)
var str = `Sunil Kumar`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}