$re = '/^\/([a-zA-Z0-9._-]+(\s?[a-zA-Z0-9._-]+|\/?))+$/m';
$str = '// Valid
/media
/media/shows
/media/movies/
/my media/shows
/my own media/movies
// Invalid
/ media/shows
/media /shows
/media/ shows
/media/shows /
/ media /shows
/ media /shows/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);