package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?x) # x- modifiers to add comments in regex
#. #any character, except newline
\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words`)
var str = `This is a sample sentence
any thing other than new line character, includs number.... 1234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}