#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(([^()]|(?R))*\)"
Local $sString = "ok, d(*, 10), hmmm, ok, d(*, 10), hmmm" & @CRLF & _
"a, b, c(1,3,4(nest)) d, ok(bruh)" & @CRLF & _
"" & @CRLF & _
"aa(aa)aaaa)(aa(aa(aa)aa)aaaa(aa(aa(aa)aa)aa)aaaaaa(aa(aa(aa(aa)aa)aa)aa)aa" & @CRLF & _
"" & @CRLF & _
"arg, nested(arg2, another(ok)), arg3, call(this)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")