#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)System\.out\.println\(\"[^\":]*\s(?:job|jb?c)\s[^\":]*:[^\"]*\"[^)]*\);"
Local $sString = "System.out.println("my job code is: " var.jobcode);" & @CRLF & _
"" & @CRLF & _
"System.out.println("my jc is: " var.jc);" & @CRLF & _
"" & @CRLF & _
"System.out.println("my jbc is: " var.jbc);" & @CRLF & _
"" & @CRLF & _
"System.out.println ("component printout: item"); System.out.println (""); <td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">Job Codes</td><td style="word-break: break-all;word-wrap:break-word;font-size:12px;" class="FONTSTYLE" align="left">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")