using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(02 A1 )([0-9A-Z \n]{18,22})( 03)";
string input = @"02 A1 71 F0 FF FF 00
94 00 03";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}