# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Pop,|,Pop|^Pop$//gm;t' <<< "Pop
Pop,R'n'B,Classic Rock
Dance,Pop,R'n'B,Classic Rock
Dance,R'n'B,Pop"