import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Pop,|,Pop|^Pop$";
final String string = "Pop\n"
+ "Pop,R'n'B,Classic Rock\n"
+ "Dance,Pop,R'n'B,Classic Rock\n"
+ "Dance,R'n'B,Pop";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}