// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Pop,|,Pop|^Pop$").unwrap();
let string = "Pop
Pop,R'n'B,Classic Rock
Dance,Pop,R'n'B,Classic Rock
Dance,R'n'B,Pop";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}