package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\]\[]*(?:RSVP|§)[^\]\[]*]`)
var str = `[RSVP dog] [§111] [cat]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}