#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(?'group'[\w]+)": {\s*" & @CRLF & _
"((\s*"(?'value'[^"]+)": "(?'key'[^"]+)"(?:, *" & @CRLF & _
")?)+)" & @CRLF & _
"},?"
Local $sString = ""g1": {" & @CRLF & _
" "k1": "v1"," & @CRLF & _
" "k2": "v2"," & @CRLF & _
" "k3": "v3"" & @CRLF & _
"}," & @CRLF & _
""g2": {" & @CRLF & _
" "k4": "v4"," & @CRLF & _
" "k5": "v5"," & @CRLF & _
" "k6": "v6"" & @CRLF & _
"}," & @CRLF & _
""g3": {" & @CRLF & _
" "k7": "v7"," & @CRLF & _
" "k8": "v8"," & @CRLF & _
" "k9": "v9"" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")