package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(?'group'[\w]+)": {\s*
((\s*"(?'value'[^"]+)": "(?'key'[^"]+)"(?:, *
)?)+)
},?`)
var str = `"g1": {
"k1": "v1",
"k2": "v2",
"k3": "v3"
},
"g2": {
"k4": "v4",
"k5": "v5",
"k6": "v6"
},
"g3": {
"k7": "v7",
"k8": "v8",
"k9": "v9"
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}