re = /(?<!\S)\d+(?:\s+\d+)*(?!\S)/m
str = '12 11231390 good123e41 12he12o1 1391389 dajue1290a 12331 12-10 1.2 test12.0why 12+12 12*6 2d1139013 09`29 83919 1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end