const regex = /::(.*?)::/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('::(.*?)::', 'gm')
const str = `<p>other words ::this should get matched:: other words </p>`;
const subst = `<span class='matched'>$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);