package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?:function\s+\w+\s*)\((.*)\)(?:(?:(?:\s*:\s*)(\w+.*)))`)
var str = `private static function parse(
strJson:String,
iStart:Int,
iEnd:Int) : Map<String,String>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}