const regex = /(?:function\s+\w+\s*)\((.*)\)(?:(?:(?:\s*:\s*)(\w+.*)))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:function\\s+\\w+\\s*)\\((.*)\\)(?:(?:(?:\\s*:\\s*)(\\w+.*)))', 'gs')
const str = `private static function parse(
strJson:String,
iStart:Int,
iEnd:Int) : Map<String,String>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}