use strict;
my $str = 'normal string foo bar qux
leading spaces are ok
trailing spaces are not affected ';
my $regex = qr/(?<=\S) +(?=\S)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";