import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\{classNames.*\\(\\{(?:.|\\n)*').*(?=')";
final String string = "\n"
+ " const test = {\n"
+ " 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
+ " true,\n"
+ " 'bg-blue-1/10 text-blue-1 border-blue-1': true,\n"
+ " };\n\n"
+ " className={classNames({\n"
+ " 'w-full py-1 pr-4 pl-2 cursor-pointer flex border-transparent border-l-4 rounded hover:bg-blue-1/10 hover:text-blue-1 hover:border-blue-1 font-semibold mb-2 items-center':\n"
+ " true,\n"
+ " 'bg-blue-1/10 text-blue-1 border-blue-1': open,\n"
+ " })}\n"
+ " >\n"
+ " \n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}